Apple login/signup is not working
Incident Report for
Canva
Resolved
This incident has been resolved.
Posted
Jun
10
,
2022
-
14:36
AEST
Identified
The issue has been identified and a fix is being implemented.
Posted
Jun
10
,
2022
-
14:23
AEST
×
Subscribe to Incident
Subscribe to updates for
Apple login/signup is not working
via . You'll receive .