Canva Access Issues - Indonesia

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Aug 28, 2025 - 23:23 AEST

Monitoring

We have implemented a fix for the access issues affecting users in Indonesia. We are currently monitoring the situation to ensure the issue is fully resolved and will provide updates as we verify everything is working normally.
Posted Aug 28, 2025 - 22:50 AEST

Investigating

We are currently aware of reports from users in Indonesia experiencing difficulty accessing Canva. Our team is investigating this issue and working to resolve it. We will provide updates as more information becomes available.
Posted Aug 28, 2025 - 22:28 AEST