Users from Mexico are not able to access Canva

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Mar 12, 2024 - 09:29 AEDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2024 - 19:23 AEDT

Investigating

We have received reports about users from Mexico being unable to access Canva. Our team is aware of the issue and we are currently investigating the root cause.
Posted Mar 11, 2024 - 19:13 AEDT