Background remover not working. Error message "We are having trouble loading background remover. Check your connection or try again later".
Incident Report for Canva
Resolved
Hello, thanks for your patience. This issue should now be resolved. Please refresh your browser and try again.
Posted Aug 13, 2020 - 12:31 AEST
Investigating
Hi there, we are currently having trouble loading the background remover. Our engineers are now working double-time to resolve this ASAP.
Posted Aug 13, 2020 - 12:29 AEST
This incident affected: Web Application (Edit Designs).