This is now mitigated. If you were impacted, please follow the steps below to restore your purchase.
For affected users, you can try restoring your purchase by following these steps: 1. Open the Canva app on your phone. 2. Go to Menu > tap the dropdown arrow (v) next to your account name. 3. Scroll down and tap Settings. 4. Go to the Subscription tab. 5. Tap the Restore Purchase button. 6. Wait for the confirmation message indicating success.
Thank you for your patience and understanding.
Posted Apr 28, 2025 - 22:11 AEST
Identified
For affected users, you can try restoring your purchase by following these steps: 1. Open the Canva app on your phone. 2. Go to Menu > tap the dropdown arrow (v) next to your account name. 3. Scroll down and tap Settings. 4. Go to the Subscription tab. 5. Tap the Restore Purchase button. 6. Wait for the confirmation message indicating success.
Thank you for your patience and understanding!
Posted Apr 28, 2025 - 20:26 AEST
Investigating
We’re currently experiencing an issue where new Canva Pro subscriptions and renewals made through Google Play may not immediately gain access to paid features after payment.
Our team is actively investigating the issue. We recommend users to stay tuned for further updates as we work on a fix.