Some users may have issues accessing Canva offline features

Incident Report for Canva

Resolved

This incident has been resolved.
Posted May 12, 2026 - 14:42 AEST

Investigating

Some users may have issues accessing Canva offline editing. Our teams are urgently looking into this and we will provide an update soon.
Posted May 12, 2026 - 14:15 AEST