Users are unable to download designs

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Aug 10, 2023 - 13:38 AEST

Investigating

We are currently investigating the issue wherein users are unable to download their designs.
Posted Aug 10, 2023 - 13:25 AEST
This incident affected: Downloading designs.