Users are unable to publish Canva Websites.
Incident Report for Canva
Resolved
This incident is now resolved. Thank you for your patience and understanding.
Posted Mar 14, 2023 - 05:44 AEDT
Investigating
We have become aware of an issue in which users are unable to purchase new domains or connect existing domains via the Canva Websites.

We are currently investigating the issue and will keep you updated.
Posted Mar 14, 2023 - 03:51 AEDT