Unable to download design as PowerPoint (PPT)
Incident Report for Canva
Resolved
The fix has been rolled out, and we have verified that the issue is resolved. Thanks for your patience.
Posted Apr 22, 2020 - 21:55 AEST
Update
We are continuing to investigate this issue.
Posted Apr 22, 2020 - 21:55 AEST
Investigating
We have become aware of an issue where downloading designs as PowerPoint fails for a subset of users with “Sorry, there was a technical issue. Please try again later”

Our engineers are working to resolve the issue and will keep you updated.
Posted Apr 22, 2020 - 21:46 AEST
This incident affected: Web Application (Design Downloads / Sharing).