Elements not loading on elements tab
Incident Report for Canva
Resolved
This incident has been resolved.
Posted May 31, 2022 - 03:20 AEST
Investigating
We received reports about elements not loading on the elements tab on the side panel. Users may also get errors when accessing Canva Marketplace. Our engineers are already working on it and we will post on this page any updates.

Thank you for your understanding and patience.
Posted May 31, 2022 - 01:42 AEST