We're continuing to monitor for any impact while we wait for AWS to resolve the underlying issue.
Posted May 08, 2026 - 16:01 AEST
Monitoring
We've seen recovery and are currently monitoring for any further issues.
Posted May 08, 2026 - 12:16 AEST
Identified
We’re currently experiencing intermittent issues due to an ongoing AWS service disruption. AWS has acknowledged the issue on their status page. We’re monitoring the situation closely and will update as more information becomes available. For vendor updates, see: https://health.aws.amazon.com/health/status
Posted May 08, 2026 - 10:56 AEST
Investigating
Some users may have issues accessing Canva. Our teams are urgently looking into this and we will provide an update soon.