Users may experience issues opening new and existing designs

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Apr 13, 2026 - 15:56 AEST

Monitoring

The incident is now mitigated. We will continue to monitor and resolve after confirming operations are stable.
Posted Apr 13, 2026 - 10:51 AEST

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 10:33 AEST

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 10:32 AEST

Investigating

Users may experience issues opening new and existing designs. Our engineers are working to resolve the issue.
Posted Apr 13, 2026 - 10:28 AEST