Issues managing payment methods

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Jul 29, 2020 - 08:58 AEST

Investigating

We have become aware of an issue where updating your payment method is not available and removing card option is stuck on loading.

Our engineers are working to resolve the issue and will keep you updated.
Posted Jul 29, 2020 - 05:06 AEST