Some users might experience difficulties when uploading/publishing directly to Instagram
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Jul 15, 2022 - 14:50 AEST
Monitoring
Instagram is currently experiencing issues with uploads
Posted Jul 15, 2022 - 12:32 AEST
This incident affected: Web Application (Design Downloads / Sharing).