Missing Paid Features

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Feb 14, 2025 - 18:02 AEDT

Investigating

We are aware that some users may be experiencing issues accessing paid features. Our team is aware of the situation and is actively investigating the issue. We appreciate your patience and will provide updates as we learn more.
Posted Feb 13, 2025 - 19:56 AEDT