Can't download MP4/GIF
Incident Report for
Canva
Resolved
This incident has been resolved.
Posted
Apr
18
,
2019
-
13:38
AEST
Investigating
Users are unable to download MP4/GIF
Posted
Apr
18
,
2019
-
04:21
AEST
This incident affected: Web Application (Design Downloads / Sharing).
×
Subscribe to Incident
Subscribe to updates for
Can't download MP4/GIF
via .