Some users may experience an error upon accessing their Canva designs.

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Dec 18, 2025 - 12:50 AEDT

Monitoring

We have put a fix in place and Canva has recovered. We are continuously monitoring the issue.
Posted Dec 18, 2025 - 10:28 AEDT

Update

We are currently investigating the issue and will keep you updated.
Posted Dec 18, 2025 - 09:33 AEDT

Investigating

We are currently investigating the issue and will keep you updated.
Posted Dec 18, 2025 - 09:25 AEDT