Some users may have issues using Canva

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Jul 14, 2026 - 09:17 AEST

Identified

The issue has been identified:
- Users are shown the wrong status of their subscription
Posted Jul 14, 2026 - 09:04 AEST

Investigating

Some users may have issues using Canva. Our teams are urgently looking into this and we will provide an update soon.
Posted Jul 14, 2026 - 08:57 AEST
This incident affected: Billing and subscriptions.