Users experiencing issues saving designs.
Incident Report for Canva
Resolved
This incident is now resolved. Thank you for your patience and understanding.
Posted Jan 29, 2024 - 12:51 AEDT
Identified
Users may have issues with:
- Saving designs
- Seeing changes from other collaborators

The issue resulted from unexpected issues with the planned upgrades, we estimate the issue to be mitigated in the next 40 minutes.
Posted Jan 29, 2024 - 12:26 AEDT