Users may have issues logging into Canva
Incident Report for
Canva
Resolved
This incident has been resolved.
Posted
Feb
02
,
2023
-
18:11
AEDT
Monitoring
We are currently investigating issues affecting users from logging into Canva through any platform.
Posted
Feb
02
,
2023
-
17:41
AEDT
×
Subscribe to Incident
Subscribe to updates for
Users may have issues logging into Canva
via . You'll receive .