Some users might not be able to access Canva

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding
Posted Oct 15, 2025 - 02:30 AEDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2025 - 02:21 AEDT

Investigating

We are currently investigating this issue.
Posted Oct 15, 2025 - 01:43 AEDT