Users in some countries may experience issues trying to access Canva

Incident Report for Canva

Resolved

This incident has been resolved.
Posted May 07, 2026 - 10:59 AEST

Monitoring

A fix has been implemented and we are currently monitoring for any further issues.
Posted May 07, 2026 - 10:49 AEST

Update

Users in some countries may experience issues trying to access Canva. We are currently rolling out a fix to restore service.
Posted May 07, 2026 - 10:33 AEST

Identified

Users in some countries may have issues viewing media in the Canva Editor. We are currently rolling out a fix to restore service.
Posted May 07, 2026 - 10:23 AEST

Investigating

Users in some countries may have issues viewing media in the Canva Editor. We are currently rolling out a fix to restore service.
Posted May 07, 2026 - 10:03 AEST