Some users are unable to add credit cards as a payment method

Incident Report for Canva

Resolved

This issue has been resolved
Posted Oct 29, 2025 - 06:59 AEDT

Investigating

We are currently investigating an issue where some users are unable to add credit cards as a payment method.
Posted Oct 29, 2025 - 06:03 AEDT
This incident affected: Billing and subscriptions.