Some users may be experiencing issues uploading videos to Instagram Business
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Apr 01, 2022 - 20:33 AEDT
Monitoring
We are seeing recovery in the ability to upload videos to Instagram Business. We are continuing to monitor for any further issues.
Posted Apr 01, 2022 - 18:24 AEDT
Investigating
We are working with our partners to resolve the issue as quickly as possible. If you are impacted by this issue, please try again soon.
Posted Mar 31, 2022 - 14:49 AEDT