Temporary Downtime
Incident Report for Canva
Resolved
Thank you for your patience. The incident has been resolved.
Posted 3 months ago. Jul 17, 2019 - 14:25 AEST
Update
The issue is taking longer than expected but we are already working on a fix.
Posted 3 months ago. Jul 17, 2019 - 14:01 AEST
Identified
We are currently experiencing some technical difficulties. Our engineers are working on fixing this in the soonest possible time.
Posted 3 months ago. Jul 17, 2019 - 12:28 AEST
This incident affected: Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).