Several users are having trouble accessing their designs
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Aug 23, 2021 - 12:00 AEST
Update
We are continuing to work on a fix for this issue.
Posted Aug 23, 2021 - 12:00 AEST
Identified
We are aware of the issue and currently working on it. Some users might not be able to access or edit their designs at the moment
Posted Aug 23, 2021 - 11:17 AEST
This incident affected: Mobile Applications (iPad app, iOS app, Android app) and Web Application (Design Downloads / Sharing, View Designs, Edit Designs).