Issues with using Magic Write and Magic Presentation
Incident Report for
Canva
Resolved
This incident has been resolved.
Posted
May
10
,
2023
-
00:53
AEST
Investigating
Our users are currently getting errors when using Magic Write and Magic Presentation.
We are currently investigating the issue. Thanks for your patience and understanding
Posted
May
10
,
2023
-
00:22
AEST
×
Subscribe to Incident
Subscribe to updates for
Issues with using Magic Write and Magic Presentation
via . You'll receive .