Intermittent Issues with saving designs.
Incident Report for Canva
Resolved
This has been resolved.
Posted Jul 04, 2024 - 17:35 AEST
Monitoring
This incident is now mitigated.
Posted Jul 04, 2024 - 17:17 AEST
Investigating
Some users may experience issues with saving designs. We are aware of this issue and working on having this resolved. We appreciate your patience and understanding.
Posted Jul 04, 2024 - 16:44 AEST