Dropbox is currently unavailable.
Incident Report for
Canva
Resolved
Dropbox should now be available on Canva again.
Thank you so much for your patience.
Posted
Aug
02
,
2022
-
19:02
AEST
Identified
Some users may not be able to find Dropbox in Canva. Our Product team has disabled the App and is now working on a fix.
Posted
Aug
02
,
2022
-
10:00
AEST
×
Subscribe to Incident
Subscribe to updates for
Dropbox is currently unavailable.
via . You'll receive .