Unable to import files from most apps

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 12:06 AEST

Investigating

We are currently investigating an issue wherein our users are unable to import files from most apps. We will update again once the issue is solved.
Posted Oct 01, 2025 - 10:59 AEST