Unable to access Canva due to Timeout Errors

Incident Report for Canva

Resolved

This incident has been resolved.
Posted May 27, 2025 - 12:33 AEST

Update

Access to Canva has now been restored and most users should be able to use the platform as expected.

However, we’re aware that some users may still experience issues with saving their designs. Our engineering team is actively monitoring the situation and continuing work to fully resolve these remaining issues.
Posted May 26, 2025 - 18:54 AEST

Update

We are continuing to monitor for any further issues.
Posted May 26, 2025 - 18:53 AEST

Update

We are continuing to monitor for any further issues.
Posted May 26, 2025 - 18:52 AEST

Update

Access to Canva has now been restored and most users should be able to use the platform as expected.

However, we’re aware that some users may still experience issues with saving their designs. Our engineering team is actively monitoring the situation and continuing work to fully resolve these remaining issues.
Posted May 26, 2025 - 18:25 AEST

Update

We are continuing to monitor for any further issues.
Posted May 26, 2025 - 18:06 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 26, 2025 - 17:59 AEST

Update

We are continuing to work on a fix for this issue.
Posted May 26, 2025 - 17:39 AEST

Update

We are continuing to work on a fix for this issue.
Posted May 26, 2025 - 17:21 AEST

Update

We are continuing to work on a fix for this issue.
Posted May 26, 2025 - 17:16 AEST

Identified

We’re aware of an issue where users are unable to access Canva and are encountering timeout errors when attempting to load the platform.

Our engineering team is actively investigating and working to resolve the issue as quickly as possible.
Posted May 26, 2025 - 16:50 AEST
This incident affected: Mobile Applications (iPad app, iOS app, Android app), Login and signup, Editing designs, Viewing designs, Saving designs, Downloading designs, Sharing designs, Media uploads, Home page, Projects page, Templates page, Apps, Administration and settings, Billing and subscriptions, Print and delivery, Scheduling posts, Publishing websites, Help/support, and Desktop Applications (macOS app, Windows app).