Users are unable to upload audio or uploading takes too long to complete

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted Apr 22, 2023 - 04:35 AEST

Monitoring

The issue has been identified and we are monitoring this issue.
Posted Apr 22, 2023 - 04:15 AEST