Issues with downloading designs
Incident Report for Canva
Resolved
Thank you for your patience. The downloading issue has been fixed.
Posted Mar 30, 2019 - 02:23 AEDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 30, 2019 - 02:21 AEDT
Identified
We're currently experiencing issues with downloading designs. Our engineers are working on fixing this in the soonest possible time.
Posted Mar 30, 2019 - 01:34 AEDT
This incident affected: Web Application (Design Downloads / Sharing).