Most of Canva and our features have come back online. Our team is actively investigating: - loading designs on homepage (refresh sometimes works) - slowness related issues when downloading designs - errors related to generating images/video - errors creating or finding designs
Posted Oct 21, 2025 - 03:45 AEDT
Update
Most of Canva and our features have come back online. Our team is actively investigating: - slowness related issues when downloading designs - errors related to generating images/video - errors creating or finding designs
Posted Oct 21, 2025 - 03:12 AEDT
Identified
Most of Canva and our features have come back online. Our team is actively investigating slowness related issues when downloading designs and errors related to generating images/video.
Posted Oct 21, 2025 - 02:42 AEDT
Update
Users may encounter intermittent issues using Canva, including downloading designs and generating images and videos. We are continuing to monitor.
Posted Oct 21, 2025 - 02:26 AEDT
Update
Users may encounter intermittent issues using Canva, including downloading designs and generating images and videos. We are continuing to monitor.
Posted Oct 21, 2025 - 01:54 AEDT
Update
Users may still see issues with downloading designs and generating images and videos. We are continuing to monitor.
Posted Oct 21, 2025 - 01:27 AEDT
Update
Users may still see issues with downloading designs. We are continuing to monitor.
Posted Oct 21, 2025 - 01:18 AEDT
Update
Users may still see issues with downloading designs. We are continuing to monitor.
Posted Oct 21, 2025 - 00:53 AEDT
Update
Users may still see issues with downloading designs. We are continuing to monitor.
Posted Oct 21, 2025 - 00:30 AEDT
Update
Users may still see issues with downloading designs. We are continuing to monitor.
Posted Oct 21, 2025 - 00:15 AEDT
Update
Users may still see issues with downloading designs. We are continuing to monitor.
Posted Oct 21, 2025 - 00:01 AEDT
Update
We are seeing significant recovery. Users may still see issues with downloading designs. We are continuing to monitor.
Posted Oct 20, 2025 - 23:45 AEDT
Update
We have seen the majority of functionality recovered. Users may still see issues with downloading designs.
Posted Oct 20, 2025 - 21:27 AEDT
Update
We are seeing significant recovery. We are continuing to monitor.
Posted Oct 20, 2025 - 21:07 AEDT
Monitoring
We are seeing significant recovery. We are continuing to monitor.
Posted Oct 20, 2025 - 20:56 AEDT
Identified
We are seeing some signs of recovery in some regions. We are still working with our underlying cloud provider to restore full access.
Posted Oct 20, 2025 - 20:43 AEDT
Update
We are currently experiencing significantly increased error rates which are impacting functionality on Canva. There is a major issue with our underlying cloud provider. We are working with them to restore full access as quickly as possible.
Posted Oct 20, 2025 - 20:17 AEDT
Update
We are currently experiencing significantly increased error rates which are impacting functionality on Canva. Our team is actively investigating the issue and working to restore full access as quickly as possible.
Posted Oct 20, 2025 - 19:16 AEDT
Update
We are currently experiencing significantly increased error rates which are impacting functionality on Canva. Our team is actively investigating the issue and working to restore full access as quickly as possible.
Posted Oct 20, 2025 - 19:14 AEDT
Update
We are currently experiencing significantly increased error rates which are impacting functionality on Canva. Our team is actively investigating the issue and working to restore full access as quickly as possible.
Posted Oct 20, 2025 - 19:09 AEDT
Update
We are currently experiencing significantly increased error rates which are impacting functionality on Canva. Our team is actively investigating the issue and working to restore full access as quickly as possible.
Posted Oct 20, 2025 - 19:06 AEDT
Investigating
We’re aware that Canva and its features are currently unavailable for some users. Our team is actively investigating the issue and working to restore full access as quickly as possible.