Trouble loading Canva
Incident Report for Canva
Resolved
This issue has been resolved.
Posted Dec 17, 2021 - 07:56 AEDT
Investigating
Some users are experiencing issues loading the mobile app and website. We are currently investigating this and working to fix it. We apologize for any inconvenience. Thank you for your patience.
Posted Dec 17, 2021 - 07:54 AEDT
This incident affected: Mobile Applications (iPad app, iOS app, Android app) and Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).