Can't load www.canva.com
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Jul 18, 2020 - 07:47 AEST
Investigating
Users are unable to open www.canva.com. We are currently investigating the issue. The problem appears to be caused by issues with our DNS provider.
Posted Jul 18, 2020 - 07:34 AEST
This incident affected: Mobile Applications (iPad app, iOS app, Android app) and Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).