Some users may encounter missing images/videos/fonts in the Canva Editor, Homepage, and errors downloading designs.
Incident Report for Canva
Resolved
This incident is now resolved. Thank you for your patience and understanding.
Posted Oct 26, 2022 - 06:06 AEDT
Monitoring
Cloudflare is implementing a fix. For the time being, try reloading/refreshing the page before editing and/or downloading your designs.
Posted Oct 26, 2022 - 04:25 AEDT
Identified
The issue has been identified.
Posted Oct 26, 2022 - 03:47 AEDT