Users unable to access canva.com, getting "site can't be reached"
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Jun 11, 2020 - 09:10 AEST
Update
We are continuing to investigate this issue.
Posted Jun 11, 2020 - 06:26 AEST
Investigating
We're receiving reports from users that they are unable to load canva.com and are getting a "This site can't be reached" page when trying to access the site.

We're currently investigating the issue and working hard to resolve it as soon as possible/
Posted Jun 11, 2020 - 06:20 AEST
This incident affected: Web Application (View Designs).