Unable to download designs
Incident Report for Canva
Resolved
Hello, thanks for your patience. This issue should now be resolved. Please refresh your browser and try again.
Posted Sep 02, 2020 - 06:17 AEST
Investigating
We have become aware of an issue where users are unable to download designs and getting an error message of “504 Gateway Time-out Error” when you access Canva.com.

Our engineers are working to resolve the issue and will keep you updated.
Posted Sep 02, 2020 - 04:54 AEST
This incident affected: Web Application (Design Downloads / Sharing).