Some users might experience difficulties with downloading, scheduling, print orders and website publishing
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Dec 06, 2022 - 15:25 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 06, 2022 - 11:23 AEDT
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 06, 2022 - 11:02 AEDT
Investigating
We are currently investigating this issue.
Posted Dec 06, 2022 - 09:44 AEDT
This incident affected: Web Application (Design Downloads / Sharing).