Unable to access Canva.com
Incident Report for Canva
Resolved
Hello. Thank you for your patience. The issue has now been resolved. Please refresh your browsers and try accessing Canva again.
Posted Nov 25, 2020 - 16:01 AEDT
Update
We are aware of reports that some users are encountering errors accessing Canva. We are currently working to resolve the issue.
Posted Nov 25, 2020 - 09:39 AEDT
Update
We are aware of reports that users are encountering errors accessing Canva. We are currently working to resolve the issue.
Posted Nov 25, 2020 - 05:46 AEDT
Investigating
We are aware of reports that users are encountering errors accessing Canva. We are currently working to resolve the issue.
Posted Nov 25, 2020 - 05:13 AEDT
This incident affected: Web Application (View Designs, Edit Designs).