Some users may have issues using Canva

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 00:04 AEST

Monitoring

Some users may have issues using Canva. Our teams are urgently looking into this. This issue only affects a small percentage of users. We are currently monitoring the issue.
Posted Jul 09, 2026 - 23:51 AEST

Investigating

Some users may have issues using Canva. Our teams are urgently looking into this and we will provide an update soon.
Posted Jul 09, 2026 - 22:50 AEST