Some users might have successfully paid for Canva Pro but not be able to use the service.
Incident Report for Canva
Resolved
Thank you for your patience and understanding. The issue is now resolved.
Posted Apr 20, 2022 - 11:19 AEST
Update
We're investigating reports of intermittent payment timeouts for Mexican / Brazil customers, resulting in charges without recording success in Canva systems.
Posted Apr 13, 2022 - 12:01 AEST
Investigating
We're investigating reports of intermittent payment timeouts for Mexican / Brazil customers, resulting in charges without recording success in Canva systems.
Posted Apr 13, 2022 - 11:54 AEST