Users might experience issues editing their designs
Incident Report for Canva
Resolved
This incident has been resolved. We hope everything is back to normal for you.
Posted Oct 14, 2020 - 18:01 AEDT
Update
We are continuing to investigate this issue.
Posted Oct 14, 2020 - 16:51 AEDT
Investigating
Users might experience issues editing their designs, our team is working on restoring the editing capabilities.
Posted Oct 14, 2020 - 15:45 AEDT
This incident affected: Web Application (Edit Designs).