Marketplace pages are unavailable.
Incident Report for Canva
Resolved
This incident has been resolved.
Posted Dec 14, 2021 - 01:43 AEDT
Investigating
We are having issues with some pages such as canva.com/templates

We are currently investigating and will provide an update shortly.
Posted Dec 14, 2021 - 01:38 AEDT