Intermittent errors uploading images and videos or using media editing tools

Incident Report for Canva

Resolved

This incident is now resolved. Thank you for your patience and understanding.
Posted May 21, 2026 - 16:28 AEST

Monitoring

We have implemented a fix and are monitoring the results.

A very small proportion of users may experience issues uploading new images and videos, or using functionality which edits or transforms images and videos.

We expect the issue to be fully recovered within ~20 minutes.
Posted May 21, 2026 - 15:40 AEST

Identified

Users may experience intermittent issues uploading new images and videos, or using functionality which edits or transforms images and videos.

Requests may succeed when re-attempted.

We have identified the cause of the issue and are working on a fix.
Posted May 21, 2026 - 14:56 AEST
This incident affected: Media uploads.