Users should be able to access Canva, we are monitoring the fix.

Incident Report for Canva

Resolved

This has been resolved.
Posted Apr 29, 2026 - 11:02 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2026 - 10:35 AEST

Investigating

Users should be able to access Canva, we are monitoring the fix.
Posted Apr 29, 2026 - 10:21 AEST