Simultaneous Collaboration on Designs unavailable
Incident Report for Canva
Resolved
This incident has now been resolved.
Posted Nov 06, 2021 - 03:03 AEDT
Update
We are continuing to investigate this issue.
Posted Nov 06, 2021 - 03:02 AEDT
Investigating
Users may experience difficulty opening, saving, or downloading designs Our team is currently investigating the issue and we will be posting timely updates regarding the progress.
Posted Nov 06, 2021 - 02:47 AEDT
This incident affected: Web Application (Image Uploads, Design Downloads / Sharing, View Designs, Edit Designs).