Users may experience out of date thumbnails.
Incident Report for
Canva
Resolved
This incident is now resolved and thumbnails are being processed within expected timescales.
Posted
Dec
07
,
2022
-
10:29
AEDT
Identified
The issue has been identified and a fix is being implemented.
Posted
Dec
06
,
2022
-
00:49
AEDT
×
Subscribe to Incident
Subscribe to updates for
Users may experience out of date thumbnails.
via . You'll receive .