Users may experience issues downloading designs

Incident Report for Canva

Resolved

This incident has been resolved.
Posted Nov 01, 2022 - 10:17 AEDT

Investigating

We are currently investigating this issue.
Posted Nov 01, 2022 - 10:03 AEDT
This incident affected: Downloading designs.